Jump to content


Photo

Prboom 2.5.0 For Wiz


  • Please log in to reply
29 replies to this topic

#1 Pickle

Pickle

    Mega GP Mania

  • X-treme Team
  • 4074 posts
  • Gender:Male
  • Location:Detroit, Michigan

Posted 25 January 2009 - 11:12 PM

Turns out you can set to run in 16 bpp mode.
The config file and scripts are fixed get it here
Runs great, filters turned on by default.


#2 Alex.

Alex.

    Retired

  • GP Guru
  • 4582 posts
  • Gender:Male

Posted 25 January 2009 - 11:35 PM

Pickle you're a machine, nice job yet again! smile.gif

Looks like the Wiz will have a very cool library of games by release day. It's quite amazing how much the GP2X paved the way in terms of polished software for both upcoming handhelds.

Edited by Alex., 25 January 2009 - 11:38 PM.


#3 Pickle

Pickle

    Mega GP Mania

  • X-treme Team
  • 4074 posts
  • Gender:Male
  • Location:Detroit, Michigan

Posted 26 January 2009 - 12:13 AM

QUOTE(Alex. @ Jan 25 2009, 06:35 PM) View Post
Pickle you're a machine, nice job yet again! smile.gif

Looks like the Wiz will have a very cool library of games by release day. It's quite amazing how much the GP2X paved the way in terms of polished software for both upcoming handhelds.


Thanks, I think ive met my quota for the year :-)

The only thing is the min lib, the wiz and pandora have the power using SDL or some other tranparent library should be the way to go.


#4 DigitalAnvil

DigitalAnvil

    Member

  • Member
  • PipPip
  • 21 posts

Posted 28 May 2009 - 06:15 PM

Got both Quake 1 and Quake 2 working perfectl.... can't get this to load any of my WAD files? Does this work on the latest firmware or has it only been tested on the developper Wiz? (pre v1.0.0)?

#5 fettouhi

fettouhi

    Mega GP Mania

  • GP32 Hardcore
  • PipPipPipPipPipPip
  • 527 posts
  • Location:Odense S, Denmark

Posted 28 May 2009 - 06:33 PM

QUOTE (DigitalAnvil @ May 28 2009, 08:15 PM) <{POST_SNAPBACK}>
Got both Quake 1 and Quake 2 working perfectl.... can't get this to load any of my WAD files? Does this work on the latest firmware or has it only been tested on the developper Wiz? (pre v1.0.0)?


Which version of Quake are you running? glquake or this

http://dl.openhandhe...i?0,0,0,0,30,15

Regards

André

#6 DaveC

DaveC

    Mega GP Mania

  • GP Guru
  • 9170 posts

Posted 06 June 2009 - 03:16 AM

I always had trouble getting PR Boom to work right. All I can get to work is DoomII, everything else either locks up or sends me right back to the Wiz menu (even Doom 1).

Are there any treatises, Thesises, or grad school courses offered on how to set it up to run wads?

Edited by DaveC, 06 June 2009 - 03:16 AM.


#7 forgeflow

forgeflow

    GP32 User

  • Member
  • PipPipPip
  • 99 posts

Posted 06 June 2009 - 04:06 AM

QUOTE (DaveC @ Jun 5 2009, 09:16 PM) <{POST_SNAPBACK}>
I always had trouble getting PR Boom to work right. All I can get to work is DoomII, everything else either locks up or sends me right back to the Wiz menu (even Doom 1).

Are there any treatises, Thesises, or grad school courses offered on how to set it up to run wads?


To get Doom 1 to run you have to rename doom.wad to doom1.wad, or edit the appropriate .gpe file. I figured it was easy enough to rename the .wad file. I cannot get plutonia to run, but I did get doom 1, doom 2, and TNT to run.

I can't get the music to work though. Is there something wrong with Timidity on the Wiz? Or is there something wrong with the way MIDI music was implemented on this version of PRBoom.

Edited by forgeflow, 06 June 2009 - 04:08 AM.


#8 emphy

emphy

    GP32 User

  • Member
  • PipPipPip
  • 92 posts

Posted 06 June 2009 - 10:17 AM

copy the timidity.cfg file to your doom folder, in the first line add:
dir <point to timidity folder here>
example:
dir /mnt/nand/timidity/


#9 forgeflow

forgeflow

    GP32 User

  • Member
  • PipPipPip
  • 99 posts

Posted 07 June 2009 - 02:02 PM

QUOTE (emphy @ Jun 6 2009, 04:17 AM) <{POST_SNAPBACK}>
copy the timidity.cfg file to your doom folder, in the first line add:
dir <point to timidity folder here>
example:
dir /mnt/nand/timidity/


I'm supposed to put timidity on the nand?

#10 emphy

emphy

    GP32 User

  • Member
  • PipPipPip
  • 92 posts

Posted 07 June 2009 - 02:49 PM

QUOTE (forgeflow @ Jun 7 2009, 04:02 PM) <{POST_SNAPBACK}>
I'm supposed to put timidity on the nand?


nah, sd is also fine (in that case modify the line to point to the sd).

#11 forgeflow

forgeflow

    GP32 User

  • Member
  • PipPipPip
  • 99 posts

Posted 07 June 2009 - 06:57 PM

QUOTE (emphy @ Jun 7 2009, 08:49 AM) <{POST_SNAPBACK}>
QUOTE (forgeflow @ Jun 7 2009, 04:02 PM) <{POST_SNAPBACK}>
I'm supposed to put timidity on the nand?


nah, sd is also fine (in that case modify the line to point to the sd).



It worked, thanks! Doom & music, together again. smile.gif

#12 Pickle

Pickle

    Mega GP Mania

  • X-treme Team
  • 4074 posts
  • Gender:Male
  • Location:Detroit, Michigan

Posted 07 June 2009 - 07:17 PM

QUOTE (forgeflow @ Jun 7 2009, 02:57 PM) <{POST_SNAPBACK}>
QUOTE (emphy @ Jun 7 2009, 08:49 AM) <{POST_SNAPBACK}>
QUOTE (forgeflow @ Jun 7 2009, 04:02 PM) <{POST_SNAPBACK}>
I'm supposed to put timidity on the nand?


nah, sd is also fine (in that case modify the line to point to the sd).



It worked, thanks! Doom & music, together again. smile.gif


Glad to see everyone helping each other out.
The plutonia wad should work, I will check mine again and see what i did.

#13 DigitalAnvil

DigitalAnvil

    Member

  • Member
  • PipPip
  • 21 posts

Posted 09 June 2009 - 01:55 AM

QUOTE (DaveC @ Jun 5 2009, 11:16 PM) <{POST_SNAPBACK}>
I always had trouble getting PR Boom to work right. All I can get to work is DoomII, everything else either locks up or sends me right back to the Wiz menu (even Doom 1).

Are there any treatises, Thesises, or grad school courses offered on how to set it up to run wads?


I get dumped back to the wiz menu as well (for me both don't work, doom1 or doom2.). Tried renaming the file to Doom.wad, DOOM.WAD, Doom1.wad, DOOM1.WAD and doom1.wad... no such luck (I gave it a try using upper and lower case, since there was one other game that needed its filenames to be changed to lowercase to run correctly... was hoping the same work here but no such luck)

#14 Chum

Chum

    Member

  • Member
  • PipPip
  • 13 posts

Posted 11 June 2009 - 03:00 AM

QUOTE (forgeflow @ Jun 6 2009, 05:06 AM) <{POST_SNAPBACK}>
QUOTE (DaveC @ Jun 5 2009, 09:16 PM) <{POST_SNAPBACK}>
I always had trouble getting PR Boom to work right. All I can get to work is DoomII, everything else either locks up or sends me right back to the Wiz menu (even Doom 1).

Are there any treatises, Thesises, or grad school courses offered on how to set it up to run wads?


To get Doom 1 to run you have to rename doom.wad to doom1.wad, or edit the appropriate .gpe file. I figured it was easy enough to rename the .wad file. I cannot get plutonia to run, but I did get doom 1, doom 2, and TNT to run.

I can't get the music to work though. Is there something wrong with Timidity on the Wiz? Or is there something wrong with the way MIDI music was implemented on this version of PRBoom.


To get Plutonia to run edit the Plutonia.gpe file and change "#!/bin/bash" to "#!/bin/sh". Then Plutonia will run just fine.

#15 forgeflow

forgeflow

    GP32 User

  • Member
  • PipPipPip
  • 99 posts

Posted 12 June 2009 - 10:49 PM

QUOTE (Chum @ Jun 10 2009, 10:00 PM) <{POST_SNAPBACK}>
To get Plutonia to run edit the Plutonia.gpe file and change "#!/bin/bash" to "#!/bin/sh". Then Plutonia will run just fine.

Thanks man, it works!