Jump to content


Photo

Fbreader : Free E-Book Reader For Pandora


  • Please log in to reply
33 replies to this topic

#1 zx-81

zx-81

    Mega GP Mania

  • GP Guru
  • 679 posts
  • Gender:Male
  • Location:Earth

Posted 26 July 2010 - 06:45 PM

Posted Image

Hi All,

Here is a pnd package of FBReader, the famous Free e-Book Reader.
See http://www.fbreader.org/

This is a binary patched version of the previously compiled fbreader available on http://www.angstrom-distribution.org
(i do not deserve anything, it's just a pnd package).

Pnd is available here : on my blog



Enjoy,

Zx.

#2 mali

mali

    -

  • GP32 Hardcore
  • PipPipPipPipPipPip
  • 6308 posts
  • Gender:Male
  • Location:EU

Posted 26 July 2010 - 06:48 PM

Awesome :)

#3 wrath of khan

wrath of khan

    GP Mania

  • GP32 Hardcore
  • PipPipPipPipPip
  • 400 posts
  • Gender:Male
  • Location:Ireland
  • Interests:Amiga,Dreamcast,xbox360,Ps3,and the soon to be born pandora.Reading,sci-fi,etc.

Posted 26 July 2010 - 06:52 PM

Thanks alot.

#4 Trickyhero

Trickyhero

    GP32 User

  • Member
  • PipPipPip
  • 64 posts
  • Gender:Male
  • Location:Detroit,MI

Posted 26 July 2010 - 08:46 PM

Um... Schouldn't you put that in the Archive?
Good Job though it will be a great app.

Edited by Trickyhero, 26 July 2010 - 08:47 PM.


#5 zx-81

zx-81

    Mega GP Mania

  • GP Guru
  • 679 posts
  • Gender:Male
  • Location:Earth

Posted 26 July 2010 - 08:59 PM

Um... Schouldn't you put that in the Archive?


sorry i don't understand what you mean ? anyway this is a simple pnd package. There were missing files in original version from angstrom repository that make it unusable on startup. I've added those files (help stuff) and patch/hexedit the binary to have a local version that can be run from a pnd.

#6 shaky

shaky

    Member

  • Member
  • PipPip
  • 10 posts

Posted 26 July 2010 - 09:03 PM

Thanks for this ZX81, but I can't seem to get it to run on my Pandora. The log file says it need liblinebreak and I'm not having much luck installing it from the Angstrom repo...

Edited by shaky, 26 July 2010 - 09:06 PM.


#7 atomicthumbs

atomicthumbs

    I am the king of the collectors, with hospital bed a throne.

  • GP32 Hardcore
  • PipPipPipPipPipPip
  • 2701 posts
  • Gender:Male
  • Location:XK-Masada
  • Interests:Copper, a superconductor

Posted 26 July 2010 - 09:04 PM

Can this go full screen, filling it with text?

sorry i don't understand what you mean ?

http://apps.open-pandora.org

#8 zx-81

zx-81

    Mega GP Mania

  • GP Guru
  • 679 posts
  • Gender:Male
  • Location:Earth

Posted 26 July 2010 - 09:23 PM

The required libs are the following :

libbz2.so.1 => /usr/lib/libbz2.so.1
libc.so.6 => /lib/libc.so.6
libcurl.so.4 => /usr/lib/libcurl.so.4
libdl.so.2 => /lib/libdl.so.2
libexpat.so.1 => /usr/lib/libexpat.so.1
libfribidi.so.0 => /usr/lib/libfribidi.so.0
libgcc_s.so.1 => /lib/libgcc_s.so.1
libgcrypt.so.11 => /usr/lib/libgcrypt.so.11
libgnutls.so.26 => /usr/lib/libgnutls.so.26
libgpg-error.so.0 => /usr/lib/libgpg-error.so.0
liblinebreak.so.1 => /usr/lib/liblinebreak.so.1
libm.so.6 => /lib/libm.so.6
libpthread.so.0 => /lib/libpthread.so.0
librt.so.1 => /lib/librt.so.1
libsqlite3.so.0 => /usr/lib/libsqlite3.so.0
libstdc++.so.6 => /usr/lib/libstdc++.so.6
libz.so.1 => /usr/lib/libz.so.1

Can you tell me which one is missing ... i can add them in the pnd.

Edited by zx-81, 26 July 2010 - 09:24 PM.


#9 shaky

shaky

    Member

  • Member
  • PipPip
  • 10 posts

Posted 26 July 2010 - 09:27 PM

The log file is only saying liblinebreak.so.1. I'll check the rest when I get a chance

Edited by shaky, 26 July 2010 - 09:29 PM.


#10 zx-81

zx-81

    Mega GP Mania

  • GP Guru
  • 679 posts
  • Gender:Male
  • Location:Earth

Posted 26 July 2010 - 09:36 PM

I've uploaded a new package on my blog with the two libs :

libfribidi.so.0 => /usr/lib/libfribidi.so.0
liblinebreak.so.1 => /usr/lib/liblinebreak.so.1

#11 God Ginrai

God Ginrai

    Godmaster

  • GP32 Hardcore
  • PipPipPipPipPipPip
  • 3514 posts

Posted 26 July 2010 - 09:44 PM




sorry i don't understand what you mean ?

http://apps.open-pandora.org


Except that's not what he meant. He meant http://dl.openhandhe...bin/pandora.cgi ( or just http://dl.openhandhelds.org/ )

-God Ginrai

Edited by God Ginrai, 26 July 2010 - 09:44 PM.


#12 shaky

shaky

    Member

  • Member
  • PipPip
  • 10 posts

Posted 26 July 2010 - 09:46 PM

I've uploaded a new package on my blog with the two libs :

libfribidi.so.0 => /usr/lib/libfribidi.so.0
liblinebreak.so.1 => /usr/lib/liblinebreak.so.1


Seems to work now. Thanks ZX81 :)

#13 zx-81

zx-81

    Mega GP Mania

  • GP Guru
  • 679 posts
  • Gender:Male
  • Location:Earth

Posted 26 July 2010 - 09:47 PM

As always, i upload zip/pnd on my blog and then to dl.openxxx & apps/pandora.org.

But on my blog it's always the latest/fixed version.

#14 atomicthumbs

atomicthumbs

    I am the king of the collectors, with hospital bed a throne.

  • GP32 Hardcore
  • PipPipPipPipPipPip
  • 2701 posts
  • Gender:Male
  • Location:XK-Masada
  • Interests:Copper, a superconductor

Posted 26 July 2010 - 09:49 PM

whoops. forgot about the other app place :P

#15 Lobo

Lobo

    GP Mania

  • GP32 Hardcore
  • PipPipPipPipPip
  • 439 posts

Posted 26 July 2010 - 10:05 PM

New version working here! Thanks for this.

Does it read pdf?