Jump to content


Photo

Irc Is Proving To Be The Biggest Headache Of My Life!


  • Please log in to reply
16 replies to this topic

#1 Custom Processing Unlimite

Custom Processing Unlimite

    Mega GP Mania

  • GP32 Hardcore
  • PipPipPipPipPipPip
  • 719 posts
  • Gender:Male
  • Location:Milwaukee, WI, USA
  • Interests:Martial arts and computers

Posted 19 July 2011 - 08:00 PM

I have tried Pidgin, XChat and KVIRC.... HOW DO I CONNTECT TO IRC?????????????????????????????????

I have pulled this off accidentally TWICE since the SASL crap kicked me out of easily using Pidgin... I can't seem to consistantly connect (even purging settings from XChat and KVIRC and following the instructions on their respective websites leaves me dumbfounded!

The server just keeps connecting, disconnecting and reconnecting....

I've tried every /msg and /msg nickserv option I could find... and still nothing!!!! WTF!!!!!!!

#2 Blue Protoman

Blue Protoman

    GP Mania

  • GP32 Hardcore
  • PipPipPipPipPip
  • 391 posts

Posted 19 July 2011 - 09:39 PM

Try webchat.freenode.net in your browser of choice. Hit up #openpandora. We don't bite too much. ;)

#3 Custom Processing Unlimite

Custom Processing Unlimite

    Mega GP Mania

  • GP32 Hardcore
  • PipPipPipPipPipPip
  • 719 posts
  • Gender:Male
  • Location:Milwaukee, WI, USA
  • Interests:Martial arts and computers

Posted 19 July 2011 - 09:43 PM

I should note a stipulation (which is the reason I haven't done the web-based stuff yet) is that I like to log my convos so I can refer to them when I have an issue and am not able to be online...

#4 Blue Protoman

Blue Protoman

    GP Mania

  • GP32 Hardcore
  • PipPipPipPipPip
  • 391 posts

Posted 20 July 2011 - 02:37 AM

Assuming you're on the Pandora, try clearing the appdata folders and try again?

#5 Custom Processing Unlimite

Custom Processing Unlimite

    Mega GP Mania

  • GP32 Hardcore
  • PipPipPipPipPipPip
  • 719 posts
  • Gender:Male
  • Location:Milwaukee, WI, USA
  • Interests:Martial arts and computers

Posted 20 July 2011 - 02:43 AM

was on the pandora (before screen death) but having the same issues on the desktop too...

clearing config files does not help me either... no idea why, but it doesn't...

Edited by Custom Processing Unlimite, 20 July 2011 - 02:44 AM.


#6 skeezix

skeezix

    Mega GP Mania

  • GP Guru
  • 5088 posts
  • Gender:Male
  • Interests:Blog: http://www.rjmitchell.ca/~jeff/blog2009/

Posted 20 July 2011 - 03:00 AM

<nerd>
ssh/slogin to your varoite backend shell machine, use IRC (naim, irssi, etc) and alpine/pine/elm/mutt/etc for email, all under a multiplexing 'screen' session; detachgm reattach later... total win.
</nerd>

nerd++:
telnet/ssh into my bbs from your handheld (pandora, phone, etc.)

You will textgasm.

jeff

#7 Custom Processing Unlimite

Custom Processing Unlimite

    Mega GP Mania

  • GP32 Hardcore
  • PipPipPipPipPipPip
  • 719 posts
  • Gender:Male
  • Location:Milwaukee, WI, USA
  • Interests:Martial arts and computers

Posted 20 July 2011 - 06:01 AM

???

#8 Lomaxx

Lomaxx

    GP32 Hardcore

  • Member
  • PipPipPipPip
  • 127 posts

Posted 20 July 2011 - 08:42 AM

skeezix just tried to tell you that he likes text-based applications without a graphical user-interface for IRC and mailing, because they are quite flexible. ;) Not that much of an answer to your question, still i understand his enthusiasm.

Back to your question. Maybe we first should stick to one programm. For example: xchat. Could you please be more specific about what you try in xchat to connect and what exactly have been the error-messages? What is the way you connect to the internet?

I for myself just tried xchat on my pandora for the first time in the following way:

- connected my Pandora with the use of USB-networking to my desktop-linux-pc, which is configured to share internet with the USB-connected Pandora. My desktop-pc is connect via LAN to a router. The router forwards tcp-port 113 to my desktop-pc where oident is running.

- started xchat
- selected freenode-server
- joined #openpandora

So far it did not disconnect or anything during the last 5 minutes.

Edit: I just had a chat with Ivanovic in #openpandora. He said that that the port-forwarding and oident is not needed for a working connection. I must admit that i set that up years ago and do not remember why i did. =P So in theory it should just be: start xchat-> connected to freenode-server in the list -> join #openpandora. or use the command "/server irc.freenode.net -j #OpenPandora"

Edited by Lomaxx, 20 July 2011 - 09:03 AM.


#9 sebt3

sebt3

    homebrew player (P. & C.)

  • GP32 Hardcore
  • PipPipPipPipPipPip
  • 1897 posts
  • Gender:Male
  • Location:QC

Posted 20 July 2011 - 11:08 AM

was on the pandora (before screen death) but having the same issues on the desktop too...

Sound like your ISP doesnt like IRC. But I understand it : Anonymus is using IRC, so you're just trying to hack the planet. you hardcore pirat !

#10 WizardStan

WizardStan

    Mega GP Mania

  • X-treme Team
  • 6115 posts
  • Gender:Male

Posted 20 July 2011 - 12:41 PM

A lot of ISPs block as many outgoing ports as they can get away with. I'm considering setting up a port forwarding service on my home system attached to port 88 just to get around some systems when I'm out and about.

#11 skeezix

skeezix

    Mega GP Mania

  • GP Guru
  • 5088 posts
  • Gender:Male
  • Interests:Blog: http://www.rjmitchell.ca/~jeff/blog2009/

Posted 20 July 2011 - 01:39 PM

WizStan -- ssh tunnel ftw :) (and run a http proxy at home as well, for filtering and privacy!)

Lomaxx -- it was also really late :) But to point .. as the pandoras wifi for some is still not too speedy, or unreliable, using a screen session around a text set of apps is both very fast (text is fast!) and handles pesky disconnects effortlessly (just reconnect and re-attach). Mind you, a native IRC client is pretty fast too (text is text), but I do like to remind people that text clients still exist :)

jeff

#12 Custom Processing Unlimite

Custom Processing Unlimite

    Mega GP Mania

  • GP32 Hardcore
  • PipPipPipPipPipPip
  • 719 posts
  • Gender:Male
  • Location:Milwaukee, WI, USA
  • Interests:Martial arts and computers

Posted 20 July 2011 - 03:58 PM

If the ISP was blocking, wouldn't I also have issue using web-based IRC? not sure on that one, so figured I'd ask... since I CAN connect via webchat.freenode.net just fine. Situation is this:

- open XChat
- set name(s)
- select server
- edit server (add registered password)
- connect
- attempt to join chat (no error, it just sits and stares back at me when I type "/join #openpandora")
- disconnects after SASL timeout (it just decided to miraculously connect when I tried to get the SASL message I always get)
- repeats connect and disconnect until I get tired of it and shut it down

This moment is one of those random occurances where XChat just worked for me on the first try... next time I have an issue, I will post the exact message I get....

#13 sebt3

sebt3

    homebrew player (P. & C.)

  • GP32 Hardcore
  • PipPipPipPipPipPip
  • 1897 posts
  • Gender:Male
  • Location:QC

Posted 20 July 2011 - 04:02 PM

If the ISP was blocking, wouldn't I also have issue using web-based IRC? not sure on that one, so figured I'd ask... since I CAN connect via webchat.freenode.net just fine. Situation is this:

the real irc client is running on webchat.freenode.net, all your ISP see when you connect to this web client is http requests (like any normal web pages)

#14 Custom Processing Unlimite

Custom Processing Unlimite

    Mega GP Mania

  • GP32 Hardcore
  • PipPipPipPipPipPip
  • 719 posts
  • Gender:Male
  • Location:Milwaukee, WI, USA
  • Interests:Martial arts and computers

Posted 20 July 2011 - 04:13 PM

I'd be happy if I could get pidgin to do IRC again... but that seems like a null topic at this point...

#15 WizardStan

WizardStan

    Mega GP Mania

  • X-treme Team
  • 6115 posts
  • Gender:Male

Posted 22 July 2011 - 02:34 AM

WizStan -- ssh tunnel ftw :) (and run a http proxy at home as well, for filtering and privacy!)

Indeed, but I'm a little hesitant to just start an ssh server with port 80 or 88. I don't even like keeping it on 22 if I can help it.